There is no site configured for this Project 2013, Project Site is not created automatically

There is no site configured for this Project 2013

In this post, we will explain why Project Site is not created automatically in Project Server 2013 to avoid There is no site configured for this Project 2013 issue.

There is no site configured for this Project 2013

You might also like to read Missing Site Creation Settings In Project Server 2016.


There is no site configured for this Project 2013

In Project Server 2013, when I tried to create a new project from Project Center as shown below:

Create New Project in Project Server

I have noted that the Project was created successfully, but when I tried to open its connected Project Site.

open connected Project Site

I got the below message

There is no site configured for this project

There is no site configured for this project PWA

Why Project Site is not created automatically in Project Server 2013?

There is no site configured for this project 2013 issue usually occurs because of the Site Creation Settings is by default set to do not create a site when a project is published in Project Site Provisioning Settings.

Project Site Provisioning Settings

Solving: There is no site configured for this Project PWA

To avoid “There is no site configured for this project” issue in Project Server 2013, you should allow “Automatically create a site on first publish” by doing the following:

Configure Project Site Provisioning Settings in Project Server 2013

  • Open Central Administration > General Application Settings > Manage PWA Settings.
General Application Settings - Manage PWA Settings
  • If you have multiple PWA instance, don’t forget to select Project Web Instance as shown below:
Select Project Web App Instance
  • Below the “Operational Policies“.
  • Click on “Project Site Provisioning Settings“.
Operational Policies in Project Server

Note, in Project Server 2016, this option has been moved from Central Administration to PWA Settings in PWA instance.

For more details, please check Missing Site Creation Setting in Project Server 2016

Configure Project Site Creation Settings in Project Server 2013

  • Beside “Site Creation Settings” > Check “Automatically create a site on first publish“.
Automatically create a site on first publish
  • Try now to Create a new project in the Project Center.
  • Once the project created and published successfully, check its project site.
open connected Project Site
  • Great, the project site should be created automatically once the project is published.
There is no site configured for this Project PWA

If you still getting “There is no site configured for this Project 2013” message although you have configured the site creation settings to Automatically create a site on first publish. so you should check the queue job to find if there is any issue raised during creating the new project.

You might also like to read WorkflowCheckinNotify.ProjectCheckinNotifyWorkflowMessage

Conclusion

In conclusion, we have learned how to configure Project Site Provisioning Settings and allow Automatically create a site on first publishing to avoid “There is no site configured for this Project 2013” issue in Project Server 2013.

Applies To
  • Project Server 2013.
You might also like to read
Have a Question?

If you have any related questions, please don’t hesitate to ask it at deBUG.to Community.

8 thoughts on “There is no site configured for this Project 2013, Project Site is not created automatically”

  1. Pingback: Change Project Site URL in Project Server 2013 | SPGeeks

  2. I can’t find the “Site Creation Settings” section under “Project Site Provisioning Settings”! I am using project server 2016. Does anyone have this issue?

  3. Your blog helped not once but many a times when in need. Please continue your work. It helps a lot.

Leave a Reply